Back to overview
Degraded

AWS Outage

Oct 20 at 09:18am CEST
Affected services
Web Console
Web Console

Resolved
Oct 20 at 11:27am CEST

AWS has applied initial mitigations, and all services are now back online. The incident has been resolved.

Created
Oct 20 at 09:18am CEST

We were partially affected by the AWS global outage between 9:00 AM and 11:15 AM, which impacted some of our services.

  • Help Center — temporarily unreachable during the outage
  • Chat with Sales and Technical Support — unavailable during the outage
  • Subscription activation and management — intermittently unavailable for some users during the outage