Back to overview
Degraded

Payment cards issued by CSOB cannot be processed

Mar 14 at 11:45am CET
Affected services
Web Console

Resolved
Mar 16 at 10:51am CET

We are able to accept payment cards issued by CSOB again.

Updated
Mar 14 at 11:46am CET

We work on update for accepting payment cards from CSOB, but the resolution time depends on our payment processor Braintree.

Created
Mar 14 at 11:45am CET

Payment cards issued by CSOB cannot be processed via our Braintree payment processor. Please contact us at support@meetingroomapp.com to resolve this issue.